함수 이름의 의미

아래 함수의 결과 값은 숫자일까 문자일까? 아니면 배열일까? 코드 리뷰에서 이 코드를 만다게 된다면 분명 누군가 물어볼 것이다. 무슨 카운트요?

function hitCount() {}

이름만으로 예상하면 마이너스 값이 아닌 단 하나의 정수를 기대한다. 물론 함수 내용을 보면 명확하지만 수많은 함수의 내용을 매번 확인하는 것은 번거롭다. 물론 좋은 툴을 사용하고 있다면 함수 이름 위에 마우스를 쓱 올리면 결과 값의 타입을 알 수 있겠지만 마우스로 함수 이름을 찾아다니는 것도 귀찮은 일이다. 함수 이름을 만드는 것은 사람마다 기준이 다르겠지만 Count라고 이름을 지었다면 숫자를 돌려주는 것이 맞다. 언제 어느 사람이 이 코드를 읽을지 모르기 때문에 함수 이름은 동작이나 결과 값을 예측할 수 있어야 한다. 잠깐만 그런데 이 함수 이름이 이상하지 않은가? 구글에서 번역하면 조회수라는 의미다.

hit count === 조회수

동사를 함수 이름으로 사용한 것은 좋은데 뭔가 이상하다. 조회수를 얻으려면 이 코드가 좋겠다.

function getHitCount() {}

아니면 이건 어떨까?

function getBlogHitCount() {}

내가 작성하는 함수의 이름만큼은 조금 더 고민해서 만들기로 마음먹었다. 함수 이름은 의미가 있어야 하고 더 궁금하지 않을 만큼만 자세하면 된다고 생각한다. 좋은 툴을 쓰든 TypeScript를 쓰든 상관없이 말이다.

Categories: JavaScript, readableCode

Originally published at http://agvim.wordpress.com on June 27, 2020.

--

--

JavaScript Developer, https://afrontend.github.io/

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store